For Sponsored Posts & Articles, please email us on 📧 networks.baseline@gmail.com

Port Channel on Cisco Catalyst 8300 SDWAN devices

Port Channel on Cisco Catalyst 8300 SDWAN devices

It is important to understand the port channel configuration on the Cisco Viptela SDWAN router and we are going to configure it on Cisco Catalyst 8300/8500 SDWAN router through CLI.

We can have two scenarios, where we have port channel configured on the service side VPNs with the traditional LAN environment or with the SD-Access LAN environment. Here in this article we will show you the configuration on the SDWAN side through the CLI on the Cisco cEdge catalyst 8300.

Fig 1.1- Etherchannel on Cisco Catalyst 8300 SDWAN devices

Before we start, there are some restrictions and these are as below

Restrictions for Cisco SD-WAN EtherChannel

  • The EtherChannel feature is supported only on the service-side VPN.
  • You can configure EtherChannel on a device by using the CLI, or using only the CLI templates or CLI add-on feature templates in Cisco vManage.
  • Network Interface Modules (NIMs) with L2 ports do not support EtherChannel on the service-side VPN.
  • The EtherChannel Quality of Service (QoS) feature on port channels is not supported on the service-side VPN.
  • The Aggregate EtherChannel QoS EtherChannel Quality of Service feature on port channels are not supported on the service-side VPN.
  • An EtherChannel does not support Digital Signal Processor (DSP) farm services and voice services.

Step 1: Configure a Layer 3 port channel on the cEdge catalyst 8300

NDNA_C8K# config-transaction 
NDNA_C8K(config)# interface Port-channel 99
NDNA_C8K(config-if)# ip address 10.10.10.1 255.255.255.0

Step 2: Assign Interfaces to Layer 3 port channel using active/passive channel group

NDNA_C8K# config-transaction 
NDNA_C8K(config)# interface GigabitEthernet Gi1/0/1
NDNA_C8K(config-if)# no ip address 
NDNA_C8K(config-if)# channel-group 99 mode active
NDNA_C8K(config-if)# exit 

NDNA_C8K(config)# interface GigabitEthernet Gi1/0/2
NDNA_C8K(config-if)# no ip address 
NDNA_C8K(config-if)# channel-group 99 mode active
NDNA_C8K(config-if)# exit 

Step 3: Configure LACP EtherChannel

NDNA_C8K# config-transaction 
NDNA_C8K(config)# lacp system-priority 1 
NDNA_C8K(config)# interface GigabitEthernet Gi1/0/1 
NDNA_C8K(config-if)# lacp port-priority 1 

Step 4: Enable Flow Based Load Balancing Per Port Channel

NDNA_C8K(config)# interface Port-channel 99
NDNA_C8K(config-if)#load-balancing flow

Output on the Catalyst 8300 SDWAN for flow-Based Port-Channel Load Balancing

!
port-channel load-balancing vlan-manual
ip source-route
!
interface Port-channel99
 ip address 10.10.10.1 255.255.255.0
 no negotiation auto
 load-balancing flow
!
interface GigabitEthernet1/0/1
 no ip address
 negotiation auto
 cdp enable
channel-group 99
!
interface GigabitEthernet1/0/2
 no ip address
 negotiation auto
 cdp enable
 channel-group 99
!

No comments

Note: Only a member of this blog may post a comment.