For Sponsored Posts & Articles, please email us on 📧 networks.baseline@gmail.com

Part 2: Cisco Router commands reference guide : RIP and OSPF

Today we will going to talk about the Cisco commands used on the router and how they are configured. 

Here we start with the part 1 where we will start with the some of the Cisco router commands. We already discuss some of the commands for Cisco switch earlier

Fig 1.1- Sample WAN topology

Inter-VLAN routing: Configuring Router-On-Stick 
NDNA_R1(config)#interface fastEthernet 0/2
NDNA_R1(config-if)#no shutdown
NDNA_R1(config)# interface fastEthernet 0/2.50
NDNA_R1(config-subif)# encapsulation dot1q 50
NDNA_R1(config-subif)#ip address 192.168.1.1 255.255.255.0
NDNA_R1(config-subif)# interface fastEthernet 0/2.60
NDNA_R1(config-subif)# encapsulation dot1q 60
NDNA_R1(config-subif)#ip address 192.168.2.1 255.255.255.0

RIPv2 Configuration
NDNA_R1(config)#router rip 
NDNA_R1(config-router)#version 2
NDNA_R1(config-router)#network 172.16.0.0 
NDNA_R1(config-router)#no auto summary
NDNA_R1(config-router)#passive-interface serial 0/1

RIPv2 show commands for Verification
NDNA_R1#show ip protocols
NDNA_R1#show ip route
NDNA_R1#show ip route rip
NDNA_R1#show ip route 172.16.1.1

OSPF Configuration
NDNA_R1(config)#router ospf 10 (process ID)
NDNA_R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
NDNA_R1(config-router)#network 172.16.8.0 0.0.7.255 area 0
NDNA_R1(config-router)#network 192.168.1.254 0.0.0.0 area 1

Loopback configurations
NDNA_R1(config)#interface loopback 0
NDNA_R1(config-if)#ip address 1.1.1.1 255.255.255.255

Change Hello and Dead intervals per interface
NDNA_R1(config-if)#ip ospf hello-interval 2
NDNA_R1(config-if)#ip ospf dead-interval 6

Changing interface cost, bandwidth & reference-bandwidth 
NDNA_R1(config-if)#ip ospf cost 55
NDNA_R1(config-if)#bandwidth 128 (Kbps)
NDNA_R1(config-router)#auto-cost reference-bandwidth 1000 (Mbps)

Disabling OSPF on a certain interface
NDNA_R1(config-router)#passive-interface serial 0/1
NDNA_R1(config-if)#ip ospf authentication null
NDNA_R1(config-if)#ip ospf authentication
NDNA_R1(config-if)#ip ospf authentication-key cisco
NDNA_R1(config-if)#ip ospf authentication message-digest
NDNA_R1(config-if)#ip ospf message-digest-key 1 md5 cisco

Configure maximum equal-cost paths
NDNA_R1(config-router)#maximum paths 6

OSPF verification
NDNA_R1#show ip protocols
NDNA_R1#show ip route
NDNA_R1#show ip route ospf
NDNA_R1#show ip ospf neighbors
NDNA_R1#show ip ospf database
NDNA_R1#show ip ospf interfaces serial 0/1

No comments

Note: Only a member of this blog may post a comment.