Latest

Part 1: Cisco Router commands reference guide

Part 1: Cisco Router commands reference guide

Today we will going to talk about the Cisco commands used on the router and how they are configured. 

Here we start with the part 1 where we will start with the some of the Cisco router commands. We already discuss some of the commands for Cisco switch earlier

Part 1: Cisco Router commands reference guide
Fig 1.1- Sample WAN Topology

Router(config)#hostname NDNA_R1 
NDNA_NDNA_R1(config)#enable secret cisco 

Commands on line con 0
NDNA_NDNA_R1(config)#line con 0 
NDNA_NDNA_R1(config-line)#password cisco 
NDNA_NDNA_R1(config-line)#login
NDNA_NDNA_R1(config-line)#logging synchronous 
NDNA_NDNA_R1(config-line)#exec-timeout 30 0 
NDNA_NDNA_R1(config-line)#exit

Commands for vty 0 4 
NDNA_NDNA_R1(config)#line vty 0 4
NDNA_NDNA_R1(config-line)#password cisco
NDNA_NDNA_R1(config-line)#login
NDNA_NDNA_R1(config-line)#logging synchronous 
NDNA_NDNA_R1(config-line)#exec-timeout 30 0 
NDNA_NDNA_R1(config-line)#exit 

Commands for aux 
NDNA_NDNA_R1(config)#line aux 0
NDNA_NDNA_R1(config-line)#password cisco
NDNA_NDNA_R1(config-line)#login
NDNA_NDNA_R1(config-line)#logging synchronous 
NDNA_NDNA_R1(config-line)#exec-timeout 30 0 
NDNA_NDNA_R1(config-line)#exit 

Banner Command
NDNA_R1(config)#banner motd $
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 
UNAUTHORIZED ACCESS IS PROHIBITED
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
$

Other commands
NDNA_R1(config)#alias exec c configure terminal 
NDNA_R1(config)#alias exec s show ip interface brief 
NDNA_R1(config)#alias exec sr show running-config 
NDNA_R1(config)#no ip domain-lookup 
NDNA_R1(config)#service password-encryption 
NDNA_R1(config)#ip domain-name www.thenetworkdna.com 
NDNA_R1(config)#username admin password cisco 
NDNA_R1(config)#crypto key generate rsa
How many bits in the modulus [512]: 1024 
NDNA_R1(config)#ip ssh version 2 
NDNA_R1(config)#line vty 0 4
NDNA_R1(config-line)#login local
NDNA_R1(config-line)#transport input telnet ssh

Configuring router interfaces
NDNA_R1(config)#interface fastEthernet 0/2
NDNA_R1(config-if)#description LAN downlink
NDNA_R1(config-if)#ip address 192.168.1.1 255.255.255.0 
NDNA_R1(config-if)#no shutdown
NDNA_R1(config-if)#exit 
NDNA_R1(config)#interface serial 1/0/1
NDNA_R1(config-if)#description WAN uplink
NDNA_R1(config-if)#ip address 10.1.1.1 255.255.255.252
NDNA_R1(config-if)#clock rate 128000
NDNA_R1(config-if)#no shutdown