For Sponsored Posts & Articles, please email us on ­čôž networks.baseline@gmail.com

A quick study about Multi-chassis EtherChannel(MEC) in Cisco Catalyst Switches

 Today I am going to talk about the technology used in the enterprise or the datacenter environment for various vendors in the market. Starting from the Multi-chassis EtherChannel (MEC), Multi-chassis EtherChannel is generally used in the Cisco technology with the VSS.

Multi-Chassis EtherChannel
Multi-chassis EtherChannel (MEC) is a Layer 2 multi-path technology. This form of EtherChannel  allows a connected node to terminate the EtherChannel across the two physical Cisco Catalyst 6500/6800 Series Switches that make up the VSS leading to creating simplified loop-free Layer 2 topology. 

Cisco’s Multi-chassis EtherChannel (MCEC) solution addresses the need for inter-chassis redundancy mechanisms, where a carrier wants to “dual home” a device to two upstream points of attachment (PoAs) for redundancy.


Fig 1.1- MEC with DSLAM in MPLS environment


Using MEC in VSS topology results in all links being active and at the same time provides for a highly available topology without the dependency of Spanning Tree Protocol.

Some carriers either cannot or will not run loop prevention control protocols in their access networks, making an alternative redundancy scheme necessary. Moreover the MCEC addresses this issue with enhancements to the 802.3ad Link Aggregation Control Protocol (LACP) implementation. 

Note: Without VSS you cannot deploy an multi-channel ether channel that spans over multiple standalone Cisco catalyst 6500/6800 switch chassis. Multichassis Etherchannel (MEC) allows you to connect a server to two physically separate switches and use both connections for an active/active implementation. 

Lets talk about the basic configuration in regards to MEC and VSS for the below mentioned topology

Fig 1.2- MEC Example on Cisco Catalyst 6500/6800 Core switches


Configuration for VSS
!
switch virtual domain 10
switch mode virtual
mac-address use-virtual
dual-active detection pagp trust channel-group 202
!

Configuration on NDNA-Switch 1
!
interface Port-channel1
description VSL Link from Switch 1 no switchport
no ip address
switch virtual link 1
mls qos trust cos
no mls qos channel-consistency
!
interface ten 1/5/4
channel-group 1 mode on
interface ten 1/1/1
channel-group 1 mode on
!
interface GigabitEthernet 1/2/20
description Access Switch
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 202
switchport trunk allowed vlan 2,102
channel-protocol pagp
channel-group 202 mode desirable

!

Configuration on NDNA-Switch 2
!
interface Port-channel2
description VSL Link from Switch 2
no switchport
no ip address
switch virtual link 2
mls qos trust cos
no mls qos channel-consistency
!
interface ten 2/5/4
channel-group 2 mode on
interface ten 2/1/1
channel-group 2 mode on
!
interface GigabitEthernet1/2/20
description Access Switch
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 202
switchport trunk allowed vlan 2,102 
channel-protocol pagp channel-group 202 mode desirable
!

Configuration for MEC
!
interface Port-channel202
description Access Switch
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 202
switchport trunk allowed vlan 2,102
!

Using MEC in VSS topology results in all links being active and at the same time provides for a highly available topology without the dependency of Spanning Tree Protocol. 

Note: The virtual switching system supports a maximum number of 512 MECs.

No comments

Note: Only a member of this blog may post a comment.