For Sponsored Posts & Articles, please email us on 📧 networks.baseline@gmail.com

Switching Technique : Cisco Switch Virtual Interface (SVI) for VLAN

SVI stands for Switch Virtual Interface. We will talk about the basics of Switch Virtual Interface and the switch virtual interface configuration. SVI or so called Switch Virtual Interface is a kind of Layer 3 gateway for any VLANs in the switched network.

If we talk about Cisco switch, SVI is a kind of virtual interface on Cisco switch and is generally used to configure on Distributing/Core switches or Firewalls. Let's talk about the basics and the configuration of Switch Virtual Interface (SVI).

What is the requirement of the SVI in the Switched Networks ?
With SVIs the switch will use virtual Layer 3 interface to route traffic to other Layer 3 interface thus eliminating the need for a physical router.

In the switched networks, the switches send traffic only to hosts within the same broadcast domain (Single VLAN) and routers handled traffic between different broadcast domains (Different VLANs). This meant that network devices in different broadcast domains could not communicate without a router.

How we can achieve the SVI in the Switched Networks ?
VLANs reduce the load on a network by dividing a LAN into smaller segments and keeping local traffic within a VLAN. However, because each VLAN has its own domain, a mechanism is needed for VLANs to pass data to other VLANs without passing the data through a router. 

The solution is to use switched virtual interface – SVI. An SVI is normally found on switches (Layer 3 and Layer 2). With SVIs the switch recognizes the packet destinations that are local to the sending VLAN and switches those packets and packets destined for different VLANs are routed.

There is one-to-one mapping between a VLAN and SVI, thus only a single SVI can be mapped to a VLAN. In default setting, an SVI is created for the default VLAN (VLAN1) to permit remote switch administration.

In most typical designs we have the default gateway for the hosts pointing to the switches SVI, then the switch will route the packets to rest of the Layer 3 domain. The basic configuration is to configure the SVI is to create the Virtual interface and then provide the IP address to that interface.

Fig 1.1- Sample SVI Topology
Now we are configuring VLAN 2 as a Engineering with the IP address 192.168.10.1 which has 253 hosts where 192.168.10.1 is a network ID and 192.168.10.255 is a broadcast IP address

NB_switch1(config)#interface vlan 2                                          
NB_switch1(config-if)#description Engineering                                   
NB_switch1(config-if)#ip address 192.168.10.1 255.255.255.0  

Configuring Interface with the VLAN ID
NB_AccessSwitch(config)# interface gi1/14 
NB_AccessSwitch(config-if)# switchport mode access 
NB_AccessSwitch(config-if)# switchport access vlan 2
NB_AccessSwitch(config-if)# no shut 

Now we are configuring VLAN 3 as a HR with the IP address 192.168.20.1 which has 253 hosts where 192.168.20.1 is a network ID and 192.168.20.255 is a broadcast IP address

NB_switch1(config)#interface vlan 3                                         
NB_switch1(config-if)#description HR                                
NB_switch1(config-if)#ip address 192.168.20.1 255.255.255.0  

Configuring Interface with the VLAN ID

NB_AccessSwitch(config)# interface gi1/15
NB_AccessSwitch(config-if)# switchport mode access 
NB_AccessSwitch(config-if)# switchport access vlan 3
NB_AccessSwitch(config-if)# no shut 

NB_AccessSwitch(config)# interface gi1/16 
NB_AccessSwitch(config-if)# switchport mode access 
NB_AccessSwitch(config-if)# switchport access vlan 2
NB_AccessSwitch(config-if)# no shut