For Sponsored Posts & Articles, please email us on 📧 networks.baseline@gmail.com

Cisco Viptela SDWAN: Part 1 TLOC extension

Cisco Viptela SDWAN: TLOC extension

As you may heard about the topic TLOC-extension. By using a TLOC extension interface, a WAN Edge router can communicate with the adjacent WAN Edge router over the interface to use other WAN edge router ISP media ( MPLS/VPLS/Internet/4G/5G) 

To avoid the cost of additional IPs, tloc-extension supports dynamic load balancing across multiple transports and allows the addition of peers.

A TLOC extension links two vEdges at the same site for transport redundancy, which can either be a layer 3 link or a sub-interface link.

Fig 1.1- TLOC extension

So let us suppose if we have two vEdge/cEdges routers, and each vEdge/cEdge router connect to a different service provider transport media, likewise vEdge 1 is connected to one WAN transport MPLS and vEdge 2 is connected to WAN transport internet.

So now the situation, if one of our vEdge 1 lost the connectivity to MPLS cloud, it can use other neighbor vEdge transport as backup or redundant to reach to destination (via internet circuit).

TLOC-extension only works where you have two or more vEdges/cEdges with the same site id and placed together and is connected to different medias.

Configuration on vEdge 1:

!
interface ge0/1
description TLOC_extension_internet
ip address 10.10.10.2/30
tloc-extension ge0/0
no shutdown
 ! 
ip route 0.0.0.0/0 10.10.10.1
!
interface 
ge0/0
description mpls
ip address 30.30.30.2/30
tunnel-interface
encapsulation ipsec weight 1
color mpls restrict
allow-service all
no allow-service bgp
allow-service dhcp
allow-service dns
allow-service icmp
allow-service sshd
no allow-service netconf
no allow-service ntp
no allow-service ospf
no allow-service stun
!
ip route 0.0.0.0/0 30.30.30.1
!

Configuration on vEdge 2:

!
interface ge0/2
description TLOC_extension_MPLS
ip address 20.20.20.2/30
tloc-extension ge0/0
no shutdown
 ! 
ip route 0.0.0.0/0 20.20.20.1
!
interface ge0/0
description biz-internet
ip address 40.40.40.2/30
tunnel-interface
encapsulation ipsec weight 1
color biz-internet restrict
allow-service all
no allow-service bgp
allow-service dhcp
allow-service dns
allow-service icmp
allow-service sshd
no allow-service netconf
no allow-service ntp
no allow-service ospf
no allow-service stun
!
ip route 0.0.0.0/0 40.40.40.1
!

No comments

Note: Only a member of this blog may post a comment.