Latest

OSPF and BGP configuration setup on a vEdge Router

 OSPF and BGP configuration setup on a vEdge Router

Today We are going to discuss about the OSPF basic setup on the Cisco Viptela vEdge router. You may remember the concept of using the different VPNs on the vEdge device as defined on our earlier article (Transport VPN, Management VPN and Service-Side VPN). 

So you need to configure the OSPF on the Service-side VPN. VPN 0 is the transport VPN and carries only control traffic, and VPN 512 is the management interface.

OSPF and BGP configuration setup on a vEdge Router
Fig 1.1- OSPF and BGP on vEdge

Let's start with the basic OSPF configuration on the vEdge device

Step 1: For OSPF, configure a VPN
NDNA_vEdge# Config t
NDNA_vEdge(config)# vpn 2 ( 2 is the VPN-id used for service-side VPN)

Step 2: Configure OSPF area 0 and the interfaces that participate in that area
NDNA_vEdge(config-vpn)# router ospf 
NDNA_vEdge(config-ospf)# area 0 
NDNA_vEdge(config-area-0)# interface ge0/2
NDNA_vEdge(config-interface)# ip-address 192.168.1.0/24
NDNA_vEdge(config-interface)# no shutdown 
NDNA_vEdge(ospf-if)# exit

Step 3: Redistribute OMP routes into OSPF:
NDNA_vEdge(config-ospf)# redistribute omp
Note: You need to put this command as it is not redistributed by default.

Let's Check the OSPF configuration under VPN 2

!
vpn 2 
router 
ospf 
redistribute omp 
area 0 
interface ge0/2
exit 
interface ge0/3 
exit 
!

Let's start with the basic BGP configuration on the vEdge device

Step 1: For BGP, configure a VPN
NDNA_vEdge# Config t
NDNA_vEdge(config)# vpn 3 ( 3 is the VPN-id used for service-side VPN)

Step 2: Configure BGP to run in the VPN
NDNA_vEdge(config-vpn)# router bgp 100
NDNA_vEdge(config-bgp)# neighbor 10.10.10.1 remote-as 200
NDNA_vEdge(config-bgp)# no shut

Step 3: Configure a system IP address for the vEdge router:
NDNA_vEdge(config)# system system-ip 192.168.1.1

Let's Check the BGP configuration under VPN 3
NDNA_vEdge# show running-config vpn 3
!
vpn 3 
router 
bgp 100 
neighbor 10.10.10.1 
no shutdown 
remote-as 200